Tooltip text color on a point of a chart

Nov 6, 2013 at 3:51 PM
Edited Nov 6, 2013 at 3:58 PM
I'm having some difficulties to change the default color of a tooltip text of my chart. I actually dont know why my chart is rendering a white text color on my tooltip.

Image

Here is my code that mounts the plot:
public void LoadData(long CheckPointID)
{
    //[...]
    var lineTempSerie = new LineSeries
                        {
                            StrokeThickness = 2,
                            MarkerSize = 3,
                            MarkerType = MarkerType.Circle,
                            CanTrackerInterpolatePoints = false,
                            Title = "Temperatura",
                            MarkerStrokeThickness = 3,
                            Smooth = false,
                        };
    //[...]
    PlotModel m = ListTempPlotModel.Find(x => x.Title == "Canal " + chn);
    //[...]
    if (m != null)
    {
        if (m.Series.Count == 0)
        {
            m.Series.Add(lineTempSerie);
            m.TextColor = OxyColors.Black;
            m.SubtitleColor = OxyColors.Black;

            //List<OxyColor> colors = new List<OxyColor>(); 
            //colors.Add(OxyColors.Black);
            //m.DefaultColors = colors as IList<OxyColor>;
            break;
        }
    }            
    //tempPlotModel.Series.Add(lineTempSerie);
    //ListTempPlotModel.Add(tempPlotModel);
    }
}

public void SetUpModel(long CheckPointID)
{
    //[...]
    OxyPlot.Annotations.LineAnnotation annoTempMin = new OxyPlot.Annotations.LineAnnotation();
    OxyPlot.Annotations.LineAnnotation annoTempMax = new OxyPlot.Annotations.LineAnnotation();
    //[...]
    OxyPlot.Annotations.LineAnnotation annoHumMin = new OxyPlot.Annotations.LineAnnotation();
    OxyPlot.Annotations.LineAnnotation annoHumMax = new OxyPlot.Annotations.LineAnnotation();
    //[...]
    PlotModel tempPlotModel = new PlotModel();
    tempPlotModel.LegendTitle = "Legenda";
    tempPlotModel.LegendOrientation = LegendOrientation.Horizontal;
    tempPlotModel.LegendPlacement = LegendPlacement.Outside;
    tempPlotModel.LegendPosition = LegendPosition.TopRight;
    tempPlotModel.LegendBackground = OxyColor.FromAColor(200, OxyColors.White);
    tempPlotModel.LegendBorder = OxyColors.Black;
    tempPlotModel.LegendTextColor = OxyColors.Black;
    //[...]
}
Is there anyone to help ?

tks
Nov 7, 2013 at 8:19 AM
Edited Nov 7, 2013 at 8:20 AM
You may need to set the Foreground of your Plot in XAML:
  <oxy:Plot x:Name="plotter" Model="{Binding MyModel}"
                                 
                                  Foreground="Black">
Good luck