Remove Plot Paddings

Jan 8, 2014 at 10:29 AM

I'm trying to include the Oxyplot Heatmap series as a layer on a map using Silverlight Bing Maps.
I always have a small shift in both directions for added coordinates, and I think it is because of the padding added to the external border of the plot. Is there a way how to remove this padding so the plot area fills all the space ?

Thank you.
Jan 8, 2014 at 10:57 AM
The control template of the Plot control contains a Border:
        <ControlTemplate TargetType="{x:Type local:Plot}">
          <Border Background="{TemplateBinding Background}" BorderBrush="{TemplateBinding BorderBrush}"
                  BorderThickness="{TemplateBinding BorderThickness}">
            <Grid x:Name="PART_Grid" />
Have you tried setting the BorderThickness property to 0?
Jan 8, 2014 at 12:57 PM
Thanks for your reply.

I set 'BorderThickness' to 0 but I had the same render.
Jan 10, 2014 at 9:10 AM
How large is the shift? Can it be a layout rounding problem?