VS 2012 Express - Nuget Installation

Feb 6, 2013 at 10:29 AM
Hi everyone,

Has anyone got the OxyPlot.Wpf working on VS 2012 Express? I get the following error when trying to install the nuget package:
Error: Could not install package: 'OxyPlot.Core 2013.1.28.1'. You are trying to install this package into a project that targets '.NETFramework, Version=v4.0', but the package does not contain any assembly references that are compatible with taht framework. For more information, contact the package author.
This also happens with .NET 4.5 target. I've tried manually referencing the assemblies. The design time fails to render the Plot control, and indicates that the oxyplot assembly cannot be found, but it works in runtime.

Thanks.
Feb 6, 2013 at 3:12 PM
You are probably using an old version of NuGet.
OxyPlot.Core is a Portable library project and you need at least NuGet 2.1 for it to work.
Feb 8, 2013 at 7:33 AM
Hi tibel,
Thanks! Installing the latest NuGet did the trick.